Got A New Blu-Ray Player And HDMI Beats Me Again

The wonderful world of high-def

Got A New Blu-Ray Player And HDMI Beats Me Again

Postby SmokestackJones » Sun Dec 27, 2009 9:08 pm

Hey there,

A Blu-Ray Hook-Up Problem. Any help would be helpful:

THE PLAYERS:
A new Panasonic DMP-BD605 Blu-Ray player I got from my wife for Christmas
Our Element Electronics FLX-3210 32" HDTV I bought at Circuit City 2 years ago on Black Friday
A Dyson HDMI cable I got at Best Buy for 30 clams

THE PROBLEM:
I have never, NEVER, with either an upscaling DVD or this Blu-Ray machine, been able to get a picture on my set, no matter what the input is set on. I get fine playback with regular cables, but HDMI will not work. I've been through 3 sets of cables and 4 players, not to mention both Panasonic and Element's websites and other sites that handles this sort of things, so I'm suspecting the TV. Finally, I turn to my digital friends here. Any ideas? It would be appreciated. I just bought Star Trek BD and it's ready and rarin' to go.

-SJ
Tearing out what little hair he has left
If I'm not me, who am I? And if I'm somebody else, why do I look like me?
-Popeye

Beblach!

My reading of A Christmas Carol
User avatar
SmokestackJones
City Attorney
 
Posts: 304
Joined: Mon Aug 02, 2004 7:51 am
Location: Oklahoma City

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby mkiker2089 » Sun Dec 27, 2009 10:10 pm

I wonder if it's the TV and HDCP. Two years old isn't that old though.

You've been through the manuals so I assume it's not user error. However I find that sometimes turning off the TV and back on with the player on first helps, other times reverse it. Beyond that it could be the TV is damaged.
-Marshall-
Nun sacciu, nun vidi, nun ceru e si ceru durmiv.
I know nothing, I see nothing, I wasn't there,
and if I was there, I was asleep.
User avatar
mkiker2089
County Attorney
 
Posts: 1372
Joined: Wed Nov 20, 2002 1:45 am
Location: Utopia

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby Joel Pearce » Mon Dec 28, 2009 5:11 am

Are your players trying to put out a 1080p signal? If you can connect via an ordinary cable then set the player to output at 720p or 1080i, that may fix the problem.

Honestly, though, it kind of sounds like your television is busted.
My compulsively purchased collection
User avatar
Joel Pearce
Judge (Retired)
 
Posts: 91
Joined: Wed Sep 11, 2002 6:05 am
Location: Waterloo, Ontario

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby SmokestackJones » Mon Dec 28, 2009 10:40 am

Hey guys,

Well, I tried both suggestions, and nada. I am now pretty much convinced the TV is at fault. I thank you again for the help (a lot more than I got from either company's websites). As for me, it's back to the regular cables, as a new set isn't in the budget. My luck I'd buy an off-brand from a chain that's out of business.

Gives us a great excuse to get a bigger set later this year, though.

-SJ
If I'm not me, who am I? And if I'm somebody else, why do I look like me?
-Popeye

Beblach!

My reading of A Christmas Carol
User avatar
SmokestackJones
City Attorney
 
Posts: 304
Joined: Mon Aug 02, 2004 7:51 am
Location: Oklahoma City

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby Steve T Power » Mon Dec 28, 2009 12:43 pm

Did you try shifting to HD modes through a set of Component (red,green,blue) cables?
Most BR players will still deliver HD signals through component, up to 720p anyway.
As the ancient Tibetan philosophy states:"Don't start none... won't be none...".
User avatar
Steve T Power
Judge
 
Posts: 5351
Joined: Wed Sep 11, 2002 3:08 pm
Location: St. John's, Newfoundland, CA

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby SmokestackJones » Tue Dec 29, 2009 9:25 pm

Steve T Power wrote:Did you try shifting to HD modes through a set of Component (red,green,blue) cables?
Most BR players will still deliver HD signals through component, up to 720p anyway.


Hey Steve,

Didn't know that, I'll give it a shot. Thanks.

-SJ
If I'm not me, who am I? And if I'm somebody else, why do I look like me?
-Popeye

Beblach!

My reading of A Christmas Carol
User avatar
SmokestackJones
City Attorney
 
Posts: 304
Joined: Mon Aug 02, 2004 7:51 am
Location: Oklahoma City

Re: Got A New Blu-Ray Player And HDMI Beats Me Again

Postby Steve T Power » Wed Dec 30, 2009 4:48 am

SmokestackJones wrote:
Steve T Power wrote:Did you try shifting to HD modes through a set of Component (red,green,blue) cables?
Most BR players will still deliver HD signals through component, up to 720p anyway.


Hey Steve,

Didn't know that, I'll give it a shot. Thanks.

-SJ


Hope it works out!
As the ancient Tibetan philosophy states:"Don't start none... won't be none...".
User avatar
Steve T Power
Judge
 
Posts: 5351
Joined: Wed Sep 11, 2002 3:08 pm
Location: St. John's, Newfoundland, CA


Return to Blu-ray

Who is online

Users browsing this forum: No registered users and 3 guests

cron